× Looking for a useful answer?

Read this first and make sure you checked all steps: csvimproved.com/support/getting-started

Don't just say it doesn't work but describe in detail what is happening and add the following information:
* Version of the extension you are using
* CSVI version (Latest is not a version number)
* Sample of the file being imported
* A copy of the template you are using. Use the maintenance menu to create a backup of your template
* Collected debug information

Without this information you won't get a useful answer. If no debug log is attached, you will get a request to post it.

Where to get the debug information?

A tutorial ( csvimproved.com/support/questions-and-answers/390-how-to-collect-debug-information ) has been written to help you collect your debug information.

Import Xml for virtual codes of several articles

More
1 month 1 week ago #60449 by tharuna
tharuna replied the topic: Import Xml for virtual codes of several articles
Hello,

<KitComponents>
<Product>
<Code>107315</Code></Product>
<Quantity>1</Quantity>
</KitComponents>

You mentioned that the product code are not loaded from this part of the XML. From what i noticed from your template is that, the XML path to read the code 107315 is KitComponents/Product/Code and you have set that to Skip field and so it is skipped. You cannot have two different XML paths set to one field in import. Since there are two different XML paths for product_sku as per your XML, you need to create two different import templates. One template where XML path for product_sku will be Code(as per the current template) and the second template you need to set product_sku XML path as KitComponents/Product/Code. Let me know if it solves your issue.

Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory

Please Log in or Create an account to join the conversation.

  • liuker
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 month 1 week ago #60452 by liuker
liuker replied the topic: Import Xml for virtual codes of several articles
I would like the code 107315 in KitComponents / Product / Code to be skipped and not taken into consideration.
This:
<KitComponents>
<Product>
<Code>107315</Code></Product>
<Quantity>1</Quantity>
</KitComponents>
this must not be taken into consideration to continue reading the fields.

Unfortunately, this does not happen as it interrupts the import of the subsequent data as in the photo

Attachments:

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #60453 by tharuna
tharuna replied the topic: Import Xml for virtual codes of several articles
Hello,
Ok i think i understand the actual issue. For product 113828, under <KitComponents></KitComponents> you have two product nodes but with 118165 there is one product node. You have set one Skip field for KitComponents, KitComponents/Product and KitComponents/Product/Code which ignores one product node but there is still one more for product 113828. This works for 118165 because it has only one product node under <KitComponents></KitComponents>.What if you create one more set of skip field for KitComponents, KitComponents/Product and KitComponents/Product/Code like in the screenshot attached? Does it work for you then?

Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
Attachments:

Please Log in or Create an account to join the conversation.

  • liuker
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 month 1 week ago #60454 by liuker
liuker replied the topic: Import Xml for virtual codes of several articles
Unfortunately, even if the code 113828 has only one node, it does not generate the article but blocks the following fields, as in the photo.

I tried to make the different skips but the problem persists, I attach photo for security:

Attachments:

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #60455 by tharuna
tharuna replied the topic: Import Xml for virtual codes of several articles
Hello,
The skip fields in your template fields is not same as the one i posted. You do not have skip field set for KitComponents. Can you try creating skip field same as in the screenshot i sent?

With template fields as in my screenshot i see product 113828 loads fine. Check attached screenshot.

Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
Attachments:

Please Log in or Create an account to join the conversation.

  • liuker
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 month 1 week ago #60456 by liuker
liuker replied the topic: Import Xml for virtual codes of several articles
Unfortunately, he does not read further, I do not know what is sincerely wrong.
Attachments:

Please Log in or Create an account to join the conversation.