× Looking for a useful answer?

Read this first and make sure you checked all steps: csvimproved.com/support/getting-started

Don't just say it doesn't work but describe in detail what is happening and add the following information:
* Version of the extension you are using
* CSVI version (Latest is not a version number)
* Sample of the file being imported
* A copy of the template you are using. Use the maintenance menu to create a backup of your template
* Collected debug information

Without this information you won't get a useful answer. If no debug log is attached, you will get a request to post it.

Where to get the debug information?

A tutorial ( csvimproved.com/support/questions-and-answers/390-how-to-collect-debug-information ) has been written to help you collect your debug information.

XLS Import - 0 records

  • johnf
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 weeks 15 hours ago #60858 by johnf
johnf created the topic: XLS Import - 0 records
CSVI version: 7.12.0
Joomla version: 3.9.8
PHP version: 7.2.19

I have been using CSVI to perform a daily import of an online XLS file for the last year. Recently, my import stopped working. Now, when I 'Preview' the first few records of the import, I see the message, 'Import file contains 0 lines.' Of course, running the import does not do anything and simply posts '0' in the Records column of the Log file. However, when I open the XLS file with Google Sheets, or LibreOffice, the file opens as expected and I can view all of the records. At this point if I save the file (using LibreOffice for example) as an XLS file, the newly saved version of the file can be imported correctly by CSVI. This leads me to believe that some header information has recently changed in some XLS files and is causing trouble for CSVI. I have no control over the creation of the publicly posted online XLS file and really can't download the file manually and save it again as an XLS file every day before performing the import. Any help solving this issue would be greatly appreciated. The XLS file in question is available here .

Please Log in or Create an account to join the conversation.

More
2 weeks 13 hours ago #60859 by rolandd
rolandd replied the topic: XLS Import - 0 records
Hello,

Can you post your debug log as requested in the blue box at the top of this page? It can also be useful to post a backup of your template, so we can run the import with your template and see what happens.

This sounds like we just need to see how the information is received. Doing a manual import kind of defeats the purpose :)

Kind regards,

RolandD

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory

Please Log in or Create an account to join the conversation.

  • johnf
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 week 5 days ago #60874 by johnf
johnf replied the topic: XLS Import - 0 records
Thanks for the quick response. Per your request, I have attached the debug file and a backup of my import template.

John
Attachments:

Please Log in or Create an account to join the conversation.

More
1 week 4 days ago #60875 by rolandd
rolandd replied the topic: XLS Import - 0 records
Hello John,

Thank you for the information. We have been investigating this issue and it hasn't been easy for sure. We were able to drill it down to some bogus bytes, they cause the script not being able to read it and that is where it stops. By re-saving the file as you do now, will fix this encoding issue and it can be read for import.

There is one more thing I am going to try and see if it works but needs some time to work that out but at least wanted to give you an update on what we found so far.

Kind regards,

RolandD

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago #60876 by rolandd
rolandd replied the topic: XLS Import - 0 records
Hello John,

We seem to have figured this out. Using a different library to read the XLS file, it is now possible to import the file that you have trouble with. I am going to send you an email with the patch file for you to give a go.

Kind regards,

RolandD

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory

Please Log in or Create an account to join the conversation.

  • johnf
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 week 13 hours ago #60881 by johnf
johnf replied the topic: XLS Import - 0 records
Hi Roland,

I got the patch file and uploaded it. I received a lot of errors in the install log. I have attached the debug log that was created during the patch process.

Now, when I run the Import for the XLS file I just get a blank screen - no errors but the XLS import doesn't work at all. All other (non-XLS) Imports seem to continue to work fine.

Thanks,

John
Attachments:

Please Log in or Create an account to join the conversation.